Shift Solenoid C

Discussion in 'ZX2 1998-2004 2.0L DOHC' started by scottie0352003, Jun 5, 2008.


  1. scottie0352003

    scottie0352003 New Member

    Messages:
    26
    Likes Received:
    0
    Trophy Points:
    0
    Hi, i was wondering if anyone has ever had to replace the shift solenoid in the tranny. Its a 1998 Escort ZX2, 2.0 4 cyl. dual overhead zytec.
    I read somewhere that u can replace these one at a time. But the ford garage said that u have to replace the entire valve body, which costs 882 bucks. Or would it be cheaper to just get a new tranny.

    Any help is greatly appreciated
  2. homestead367

    homestead367 New Member

    Messages:
    516
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Indianapolis
    I dont know much about this. Is it auto or a stick. If its an auto they are difficult to work on and you would most likely want someone else to work on it. Why are you want to replace it? What is the tranny doing that makes you think you need a new shift solenoid. I would also say get a second opinion about the problem.
  3. Jaybird

    Jaybird New Member

    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    0
    Ford is blowing smoke up your a$$. Each solenoid can be replaced seperately. I had B go on me and replaced (still wasn't cheap though, almost $400 with labor).
  4. scottie0352003

    scottie0352003 New Member

    Messages:
    26
    Likes Received:
    0
    Trophy Points:
    0
    Re: solenoid

    Thanks for the reply.
    i thought Ford was blowing some smoke, i have a guy that is gonna order it for me for 80, but he said that 2 and 3 are together and 3 and 4 r together and cant be seperated, those ones r one unit. said it wasnt too hard to do, he is a tranny mechanic only.
    the car is an auto, it feels like it isnt shifting past the 3 gear and the code P0761 came out on the code reader. said it was chift solenoid c, performance or shut off.
  5. ford_obiwan

    ford_obiwan New Member

    Messages:
    303
    Likes Received:
    1
    Trophy Points:
    0
    ive never changed one but ive wiped the oil off of the bottom to stop it from dripping on me when doing a filter change/ATF fluid change
    if you are interested in what they look like check out


    http://www.transmissionpartsusa.com/F4EAT_F4AEL_solenoids_s/18455.htm


    from my book
    code P0761 shift solenoid , performance problem or stuck in off position.

    found this as well

  6. scottie0352003

    scottie0352003 New Member

    Messages:
    26
    Likes Received:
    0
    Trophy Points:
    0
    Re: solenoid

    thanks for the site and info there Ford_obiwan
    they come today so i will be working on it sunday. will let ya know if this helps the car. Will post a pic of it too.
  7. scottie0352003

    scottie0352003 New Member

    Messages:
    26
    Likes Received:
    0
    Trophy Points:
    0
    Update

    Ok, i put the new parts on the other day and no difference except that it does shift a little better. Still runs a constant 3000 rpms at 35 mph.
    I still wonder if maybe it came out of time on the exhaust side when i found that piece of old timing belt caught in the belt ont he exhaust side.

    Thanks
  8. Y2KSE

    Y2KSE New Member

    Messages:
    723
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    DuPage Co. IL
    I had P0761 last week, and after a day it went away. I was driving in heavy traffic when CEL came on, and then had code pulled. Then drove in normal traffic for a day, lite off.

    Today, I had trans fluid level checked and they said it was "too high" ? I had the tranny service done a few months ago and will have it looked at again.
  9. pextor

    pextor Moderator Staff Member

    Messages:
    3,681
    Likes Received:
    23
    Trophy Points:
    188
    Location:
    Lancaster, pa
    usually too much oil in the engine is a bad thing, but too much tranny fluid is not so bad. I think i'm a little over in my zx2. I also think I need to replace the 1-2 shift solenoid...
  10. Y2KSE

    Y2KSE New Member

    Messages:
    723
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    DuPage Co. IL
    Bringing up an older topic.

    I had PO761 code months ago and then got the transmission repaired. Now the code is back, grrrr :mad:

    I dont know it driving in heavy traffic maybe just causes the trans to shift funny and throw a code.

    I'll see of the CEL goes away before spending more $$.

Share This Page