fuel injector problem?

Discussion in '2nd Gen 1991-1996 1.9L SOHC' started by hikerrob, Oct 31, 2008.


  1. hikerrob

    hikerrob New Member

    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    0
    hi,i m having a problem with my 95 escort. i recently rebuilt the engine,and the car ran great . i broke it in gently by accelerating slowly.once i was sure the engine was fine i really hopped on the gas to check out the acceleration. it immediately quit on me. heres the deal,if i pump the gas pedal a few times, it will run for a few seconds then quit. ive swapped out the fuel pump replaced all the fuses and relays in the engine fuse box and checked out the fuses in the interior. anyone have any other ideas?
    a couple of other questions
    i have a control module from a 92 escort would this be compatable with a 95?
    i can get access to a code reader.where do you plug it in to?
    thanks rob
  2. dave8338

    dave8338 New Member

    Messages:
    921
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Annandale, MN
    Have you changed the fuel filter? The ECU will work as long as it is for the 1.9L and the OBDI is located under the steering wheel. How far did you drive the car before you noticed the problem?
  3. hikerrob

    hikerrob New Member

    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    0
    no i havent changed the fuel filter,but my gut feeling says thats not it. i was doing about 20 mph and as soon as i stepped on the gas it quit .this would lead me to belive i blew out a fuse relay or circut.thanks for letting me know the box would work im going to try swapping that out. thanks rob
  4. dave8338

    dave8338 New Member

    Messages:
    921
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Annandale, MN
    Something has me confused. :lol: You're driving 20mph and everything is fine, then you step it down a bit more and it dies and will not restart?

    When you say "rebuilt" the engine...what exactly have you done?
    There are very few "items" on a scort that will leave you stranded like that:
    1. The timing belt breaking is one of them, but you say it will restart if you pump the gas...should have NO effect.

    2. I had a friends 'scort cause him troubles and it turned out to be the fuel cut off switch that was damaged in a prior accident and never replaced. I've had mine trip while jacking the car in the shop, but that will not allow it to start at all.

    3. Could be a ECU problem but not likely: HOW FAR HAVE YOU DRIVEN THE CAR< PRIOR TO THIS PROBLEM??? :roll:

    Did you replace the fuel pump before or after the problem showed up? Was the replacement pump new or used?
  5. WJC

    WJC New Member

    Messages:
    524
    Likes Received:
    0
    Trophy Points:
    0
    Ease up on the parts swappage, and get a fuel pressure reading. Narrow it down to spark or fuel, then look at parts.

Share This Page