2002 Ford Escort ZX2...idling issues (high idle??? wtf)

Discussion in 'Tech & Repair' started by TylerSanderson, Feb 21, 2007.


  1. TylerSanderson

    TylerSanderson New Member

    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    I drive a 2002 escort zx2

    Car's been perfect until now, just started to idle really high. In drive/reverse/etc it idles around 1100-1200 rpms, sometimes higher... and when in park/neutral its up in the lower to mid 2k range. WTF?

    Can't seem to figure out what's wrong. I unplugged the IAC and nothing happened but the CEL came on... so I take it thats working. I just can't seem to figure the problem out. No vacuum leaks though.. its wierd. :?:
  2. Newfie_dan

    Newfie_dan New Member

    Messages:
    1,158
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Saskatoon, Canada
    checks

    check for any leaks in the air intake tube with carb cleaner, if thats not yeilding any results then look for engine codes possibly a tps problem, I would also clean the IAC valve and maf to ensure that these are elimintated as sources of your problems.
  3. zzyzzx

    zzyzzx FEOA Member

    Messages:
    11,031
    Likes Received:
    156
    Trophy Points:
    363
    Location:
    Baltimore, MD USA
    Check for vacuum leaks. Get a MityVac to do this.
  4. jlongoria9

    jlongoria9 New Member

    Messages:
    4,267
    Likes Received:
    1
    Trophy Points:
    0
    Location:
    Texas
    sticking IAC
  5. pyro_maniac69

    pyro_maniac69 New Member

    Messages:
    749
    Likes Received:
    0
    Trophy Points:
    0
    are you sure your car is warming up? sounds like the computer doesn't know that its warm and is keeping the idle high

Share This Page